What if I have an older version of the Stacks Wallet?

📣 Please ensure that you've installed the newest Stacks Wallet for desktop before following any instructions in this FAQ, which may not be relevant to older versions.

If you used an older version of the wallet, you should begin using the latest Stacks Wallet with the same 24-word seed phrase from that wallet.

Earlier versions of the wallet required a hardware wallet to send and receive STX. You can connect this same hardware wallet to the latest version of the Stacks Wallet software. Choose “Use existing wallet” upon opening Stacks Wallet. You don't need to create a new wallet.